Welcome to the Fiat Chrylser Automobile Owner and Enthusiast Forum Community!

Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installed an after-market stereo in a 2001 PT Cruiser and now a whole row of fuses keep blowing.?
#1
I installed a after market stereo in my wife's 2001 PT Cruiser. All wires are secure and radio/stereo works great. But now when the key auto locks are used it blows it's fuse, brake lights blow their fuse, and in dash lighting no longer works. What could cause this?
Reply
#2
It is NOT the radio's fault. Most likely pinched or abraded wires, shorting out to a metal.
Reply
#3
pt guyMy only question is this.?Why did you change the radio in the first place only to find that the entire row of fuses blew out.What you should have done is to have a professional radio installer do it and you wouldn't have to go with this kind of grief.Next time have a pro do all those things that you want done to your car. good luck
Reply
#4
I'd guess you wired the aftermarket radio incorrectly, I've installed four aftermarket radios in Chrysler products the last five or so years and have had no problems other than the first Infinity system I worked with, the speakers wouldn't work but that was my fault as I didn't "power up" the Infinity speakers.See http://www.modifiedlife.com/2001-chrysle...-diagram/I use "Scosche" wiring connectors and adapters in my installs, see http://www.scosche.com/car-audio
Content provided by Yahoo Answers.
Reply


Forum Jump:


Users browsing this thread:
1 Guest(s)